Jump to content

EXEC_REST_WS stops responding. Rest web service gets stuck


 Share

Recommended Posts

Greetings,

I was recommended to post this question here.


I'm hoping someone has encountered this problem or can point me in the right direction of where to look to solve it. Sage x3, v12

I've made a rest web service in sage x3 that I call with the ASYRRESTCLI.EXEC_REST_WS-function.
This works to begin with - I get a response from the external system with the information I want, however, when I try to get more than a certain amount of information (on our development server it seems to be more than 420kB , the EXEC_REST_WS-function either never exits, or an error message finally pops up with a "The web server has experienced the following error when processing the last query sent, the seeion is going to be cancelled: Classis session not found on this server (<some-uuid>). This can due to an unscheduled server restart.".
If I run the EXEC_REST_WS-function with the "future" parameter set to 0 instead of 1, the same thing happens, but then it's the "ASYRWEBSER.GET_FUTURE" call that never exits or pops up the error. If I alter the api call such that I get smaller page-sizes from the external system, I get more return responses with valid data with sequential calls to EXEC_REST_WS, but when the total amount recieved comes around 420kB the script gets stuck in the EXEC_REST_WS function again.

On another developer system we have, it behaves similarly, but then the function stops answering with even less data returned.

I've tried the same calls with the Postman app and I receive seemingly any amount of data without a problem, so it's not the external service limiting the data as far as I can tell.

Is there some resource I have to increase, flush or release every now and then perhaps?

Does anyone have some ideas here on what could be the problem?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...