Jump to content

Postman GraphQL Connection Details


 Share

Recommended Posts

  • 2 months later...

Hello!

I am learning about GraphQL for X3. I have taken a short introductory course on Sage University, and I have installed Postman to my local machine. I am trying to register an app, but I do not know what to enter for the Notification URI and the Redirect URI. My apologies for my ignorance. Any assistance would be greatly appreciated!

Jimmy

 

 

Link to comment
Share on other sites

Hello!

Just a follow-up. I was able to complete the API registry. I am now at the step, "Make your first API calls with Postman," and I am stuck there. Per the steps, I am editing the Postman import collection. And in the Authorization tab, I am attempting to "Get New Access Token". But am so far unsuccessful. After I fill in the fields and select "Get New Access Token," two dialogs display. One is a progress screen for "Get New Access Token." The other dialog is a Postman screen entitled, "Postman OAuth 2.0", having the menu tabs "File", "Edit", "View", and "Help", and displaying the text, "{message":""}". The process holds at this point until I "X" out of the "Postman OAuth 2.0" screen. Whereupon the other dialog status changes to "Authentication failed". My guess is that I don't have the fields entered correctly. But have not yet determined resolved this. Any help is appreciated!

Link to comment
Share on other sites

  • 9 months later...

Hello,

Just like Jimmy, I'm trying to use Postman in order to test the GraphQL API. Right now, I'm at the step "Make your first API calls with Postman", where you use an oauth2 authentification with Postman to get an access token.

I'm also stuck here, as I'm receiving the following message "{"message":""}" when I'm attempting to "Get New Access Token". The Postman console also indicate a code 404 next to the call.

I've filled the fields as shown in the quick start guide (https://developer.sage.com/x3/graphql/quick-start/make-api-calls-with-postman/), but I guess I must fill these with custom values (like my sage X3 address, ...). I also tried to fill the fields with these informations, but no results so far.

I couldn't find any example other than that, so I'd like to know if anyone managed to configure correctly these fields ? If that's the case, could you give me some explanations about which info I must enter ?

In the case this information could matter, my SageX3 is currently in 2022 R1 release, and I'm using Postman v9.20.3

Thanks a lot !

Link to comment
Share on other sites

  • 2 months later...

Same problem here. We have X3 installed in our private cloud - how does that change the URLs? Do they remain the same?

I replaced the Auth and Access token URLs with our {sageX3server}/v1/token/authorise but the response message is "unauthorised". So I wonder if the Client ID should be generated locally

So can't go past getting the access token.

Link to comment
Share on other sites

  • 2 months later...

After following the instruction provided in https://developer.sage.com/x3/graphql/quick-start/ the authentication from postman is not successfull. I am using below details to establish connection
image.png.2ef24ff51b637b65461d21d6ac2c4901.png

 

After entering the details and clicking on 'Get New Access Token' is opening below window without any option to proceed further. 

image.png.ad9f9bf737cf01d2335d94a19c868aa3.png

Please let me know, if anyone could pass through this step

Link to comment
Share on other sites

  • 7 months later...

Hello,

I'm coming back after a few month on this GraphQL subject.

Since my last message, I've manage to solve the {"message":""} issue.
In the fields "Auth URL" and "Access Token URL" (in Postman), you must fill these with the following values :

Auth URL : https://api-{your region in two letters}.sagex3.com/v1/token/authorise

Access Token URL : https://api-{your region in two letters}.sagex3.com/v1/token

The {your region in two letters} parameter is basically the region code from where you are located (ie. if you are from North America, the parameter must be "na", if you are from Europe, it will be "eu", etc. )

Once I've filled these fields and the scope, the call to get a new access token actually redirect me to the postman callback url, but this url send back another 404 error : "Could not associate the values with an active customer registered on Sage Business Cloud"

I've searched in the differents error messages provided in this page (https://developer.sage.com/x3/graphql/guides/api-error-codes/) if I could find mine, but unfortunately, no ...

My client Id and secret are coming from the values given in the App Registry Website. 

I do suspect my scope parameter isn't filled correctly, especially the customer parameter.

Does anyone know what should I put in this parameter ?

Thanks in advance.

 

PS : a bit of a brag, but if any member of the Sage Team reads this, could you please update your tutorial about setting up GraphQL API for X3 and Postman ?
Between the lack of explanation about what to use to fill the fields, indications that contradict themselves between two pages of the guide, and the short Getting started video that gives false indications on the procedure, I do think it can be improved by a lot.

  • Like 2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...